Nasza strona internetowa wykorzystuje cookies (pol.: ciasteczka)

Na naszej stronie wykorzystujemy ciasteczka (ang. cookies), dzięki którym nasz serwis może działać lepiej - więcej o tym w Naszej polityce prywatności. W każdej chwili możesz wyłączyć ten mechanizm w ustawieniach swojej przeglądarki. Korzystanie z naszego serwisu bez zmiany ustawień dotyczących cookies, umieszcza je w pamięci Twojego urządzenia.

Akceptuję   Zmiana ustawień
Zarejestruj się!

Zaloguj się!
Zapomniałeś hasła?
Witaj na legalne.info - 4856 legalnych plików, 63 użytkowników online

Strefa Mobile

Play chce przejąć Virgin Mobile Polska

Sieć Play przekazała w komunikacie informację, że podpisała szereg umów z Virgin Mobile Polska, w tym przyznającą opcję nabycia Virgin Mobile ......

Kolejne Pakiety Kibica w Orange

W związku z kolejnymi meczami polskiej reprezentacji w piłce nożnej Orange przygotowuje kolejne Pakiety Kibica.  Tak jak w poprzednich ......

Newsletter

Najnowsze wieści o legalnych programach.

Top download

Ostatnio dodane

Ostatnio na forum

Shoutbox

Data: 21-12-2009 Komentarze[2]komentarze
Gadu-Gadu
Ostatnio użytkownikom GG 7.7 (nie wiem jak to jest we wcześniejszych wersjach komunikatora) zaczęły pojawiać się komunikaty o potrzebie aktualizacji do nowszej wersji:

info_gg7

Przyzwyczajenia robią swoje i nie każdy ma ochotę używać NGG czy GG10. Przez Internet przetacza się fala krytyki na temat najnowszych wydań komunikatora GG. Na pewno ta fala niezadowolenia dociera do siedziby twórców GG, ale nikt tam nie zamierza zrezygnować z wytyczonego kursu i GG10 będzie promowane wszelkimi możliwymi sposobami. Nie po to spółka wpompowała w ten produkt ogromne środki, aby stwierdzić, że GG10 to przerost formy nad treścią i zaproponować inną wersję komunikatora.
Ostatnimi czasy dostaję zapytania, czy nie dałoby się w jakiś sposób przystosować starszych wersji GG do współpracy z numerami powyżej 17 000 000. Zabrałem się zatem do zbadania faktów i mitów na ten temat.

Fakt 1.
  • możliwe jest wysłanie wiadomości ze starszej wersji komunikatora (GG 6.x, 7.x) od osoby z numerem mniejszym niż 17 000 000 do nowszej wersji komunikatora (NGG, GG10) do osoby z numerem większym niż 17 000 000
  • niemożliwe jest wysłanie wiadomości z nowszej wersji komunikatora (NGG, GG10) od osoby z numerem większym niż 17 000 000 do osoby ze starszą wersją komunikatora (GG 6,7)
  • możliwa jest rejestracja z poziomu GG 7.7 i uzyskanie numeru powyżej 17 000 000 i zalogowanie się na niego, widać status osób z numerami poniżej 17 000 000, osoby z numerami powyżej 17 000 000 widziane są ze statusem Niedostępny
Czy zatem winna jest starsza wersja komunikatora, czy protokołu komunikacyjnego? W pewnym stopniu GG 7.7 obsługuje przecież komunikację z numerami powyżej 17 000 000.

Fakt 2.

Z ciekawości uruchomiłem zatem program przechwytujący pakiety i zrobiłem test. Okazało się, że wiadomości wysłanie z GG10 z numeru powyżej 17 000 000 w ogóle nie docierają na GG 7.7 z numerem poniżej 17 000 000! Z serwera GG nie przychodzą na GG 7.7 żadne pakiety. Zatem winien jest protokół, który nie przesyła wiadomości. Na nic zatem zdadzą się proste przeróbki w komunikatorach serii GG 6 i 7. Te komunikatory należałoby przystosować do aktualnego protokołu używanego w sieci GG. Nie jest to zadanie łatwe, a rzekłbym, że na tyle czaso i praco chłonne, że nikt się tego nie podejmie. Teoretycznie taka przeróbka jest możliwa.

Fakt 3.


Jeżeli w GG 7.7 pojawi się komunikat systemowy z obrazka powyżej, istnieje duże prawdopodobieństwo, że napisał do Ciebie ktoś z numeru powyżej 17 000 000. Przynajmniej  takie zdarzenia miały miejsce podczas prowadzonych przeze mnie testów.

Mit 1.

Czy wprowadzając blokadę w protokole, GG Team chce faktycznie wymusić przesiadkę na nielubiane, nowsze wersje GG i w ten sposób "zachęcić" do oglądania większych reklam i korzystania z nowych funkcjonalności? Tego tak do końca nie wiadomo. Ja mogę na ten temat tylko dywagować. Nie tak dawno, podczas prowadzonych prac przed uruchomieniem numerów powyżej 17 000 000, nagle wielu osobom GG 7.7 zaczęło się nagle psuć i wyłączać z błędem. Może było to właśnie spowodowane problemami z obsługą wysokich numerów przez GG 7.7 i dlatego GG Team zdecydował się na wprowadzenie blokady w protokole.

Mit 2.

Jeżeli GG Team nie wprowadziłby blokady w protokole, a GG 7.7 nie psuło tajemniczo - to całkiem możliwe, że starsze wersje GG dałoby się w prosty sposób zmodyfikować (na takiej zasadzie, jak działa modyfikacja robiona przez BK2), aby współpracowały z numerami powyżej 17 000 000.

Może Wy macie na ten temat jakieś spostrzeżenia? A może odniesie się do nich ktoś z zespołu GG?

Źródło: http://bk2.prv.pl

Wasze komentarze (2)
Dodaj swój komentarz

Autor:

Treść komentarza

Aby dodać komentarz wpisz w poniższe pole kod z obrazkaAby dodać komentarz wpisz w poniższe pole kod z obrazka:

Nie chcesz wpisywać kodu?Nie chcesz wpisywać kodu? Zarejestruj się lub zaloguj.

  up down
0
avatar

~lector -2010-01-25 18:52:32-

"Nie tak dawno, podczas prowadzonych prac przed uruchomieniem numerów powyżej 17 000 000, nagle wielu osobom GG 7.7 zaczęło się nagle psuć i wyłączać z błędem. Może było to właśnie spowodowane problemami z obsługą wysokich numerów przez GG 7.7 i dlatego GG Team zdecydował się na wprowadzenie blokady w protokole." "Czy wprowadzając blokadę w protokole, GG Team chce faktycznie wymusić przesiadkę na nielubiane, nowsze wersje GG i w ten sposób "zachęcić" do oglądania większych reklam i korzystania z nowych funkcjonalności?" Gdyby GGTeam nie chodziło o wciśnięcie ludziom na siłę GG10, to przecież niewyobrażalnie lepiej postrzegane było by wypuszczenie łatki na starsze wersje i uszanowanie wyboru ich użytkowników niż odcięcie komunikacji pomiędzy milionami użytkowników ^^

  up down
0
avatar

~radz -2009-12-22 21:50:43-

Zrobili zasobożerny kombajn.A nie wszyscy ludzie mają już wielordzeniowe procesory .gdzie jeden z rdzeni obsługiwałby GG. Poza tym nie powinni wciskać na siłę ludziom wersji Beta a z taką mamy przecież do czynienia.